SSDieselSupply.com
SSDPro-Exhaust.com

Activity Stream

Filter
Sort By Time Show
Recent Recent Popular Popular Anytime Anytime Last 7 Days Last 7 Days Last 30 Days Last 30 Days All All Photos Photos Forum Forums Groups Groups
Filter by: Popular Clear All
  • CAdiesel's Avatar
    09-02-2021, 12:43 PM
    CAdiesel started a thread Speed sensor(s) in Drivetrain
    Quick question, I have 2 vehicle speed sensors on the side of my 4l80e trans but only the front is plugged in. I've done some reading and it looks...
    4 replies | 620 view(s)
  • CAdiesel's Avatar
    10-20-2021, 11:58 AM
    Would metal flakes in the stock filter housing indicate an injection pump on the way out? They seem mildly magnetic. I have a secondary spin-on...
    3 replies | 165 view(s)
  • grancito's Avatar
    10-31-2021, 02:33 PM
    grancito replied to a thread Metal in filter housing in Engine
    Hi Mike. Good that one of the problems is cured. I put a secondary filter on the GMC truck, because particles had got into the IP. Was the smoke...
    3 replies | 165 view(s)
  • CAdiesel's Avatar
    10-28-2021, 01:22 PM
    CAdiesel replied to a thread Metal in filter housing in Engine
    Thanks, Grant. I just replaced the LP so it looks like I need to just clean out the filter housing and replace the filter. I really hate the design,...
    3 replies | 165 view(s)
  • grancito's Avatar
    10-21-2021, 02:01 PM
    grancito replied to a thread Metal in filter housing in Engine
    Hi Mike, you are loosing it, the metal is coming from the tank end of the system, perhaps the lift pump. The Lift pump over ride is a good fix for...
    3 replies | 165 view(s)
  • CAdiesel's Avatar
    09-25-2021, 01:56 PM
    CAdiesel replied to a thread Speed sensor(s) in Drivetrain
    Thanks for the info, Grant. I don't have an erratic speedo, the only indication that I do have, other than the code, is the occasional hesitation or...
    4 replies | 620 view(s)
  • grancito's Avatar
    09-23-2021, 03:22 PM
    grancito replied to a thread Speed sensor(s) in Drivetrain
    The photo was good, I didn't see the 2 sensors you mentioned, there are view obstructions on mine, but I have just managed to see them, and like...
    4 replies | 620 view(s)
  • CAdiesel's Avatar
    09-22-2021, 12:26 PM
    CAdiesel replied to a thread Speed sensor(s) in Drivetrain
    Grant, thanks for getting back to me, sorry for the delay in reply... I see what you're talking about with the internal solenoid connector. On the...
    4 replies | 620 view(s)
  • grancito's Avatar
    09-02-2021, 02:31 PM
    grancito replied to a thread Speed sensor(s) in Drivetrain
    Shit, my post was lost. On the side of my trans, half way along is the connection for the internal solenoids. On the top of the trans to transfer...
    4 replies | 620 view(s)
No More Results