SSDieselSupply.com
SSDPro-Exhaust.com

Activity Stream

Filter
Sort By Time Show
Recent Recent Popular Popular Anytime Anytime Last 7 Days Last 7 Days Last 30 Days Last 30 Days All All Photos Photos Forum Forums Groups Groups
  • grancito's Avatar
    08-10-2020, 10:50 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    Good, Walt was helpful with my engine, I hope he comes up with a solution, I'll wait for results.
    49 replies | 429 view(s)
  • CAdiesel's Avatar
    08-10-2020, 10:32 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Thanks Grant. I’ve been in contact with Walt. He’s been really helpful. I’ll let you know what I find out. All indications point to the lifters not...
    49 replies | 429 view(s)
  • grancito's Avatar
    08-10-2020, 02:19 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    Send SSD an email, they are helpful, the parts are theirs, and they may have seen the problem before.
    49 replies | 429 view(s)
  • grancito's Avatar
    08-10-2020, 02:59 AM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    There is so much "use silicone instead of gaskets" these days, I had to ask. The mineral spirits question ......? What is it other than a non...
    49 replies | 429 view(s)
  • CAdiesel's Avatar
    08-10-2020, 01:29 AM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    It’s a worthwhile question... yes I did. I’ve been thinking about it a lot and what has changed during rebuild, considering it did run before I...
    49 replies | 429 view(s)
  • grancito's Avatar
    08-10-2020, 12:58 AM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    I bought the lifters rods and rockers from rock auto because SSD didn't stock all of the parts, they worked fine, then bought 2 heads from SSD and...
    49 replies | 429 view(s)
  • CAdiesel's Avatar
    08-09-2020, 11:17 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    All the push rods on the drivers side are the same length as the old one I kept. I’ll pull the passenger side out tomorrow and check them. I...
    49 replies | 429 view(s)
  • grancito's Avatar
    08-09-2020, 10:08 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    It is now more confusing because both heads have a compression problem. You need to measure a push rod length, and compare with an old one. Where did...
    49 replies | 429 view(s)
  • CAdiesel's Avatar
    08-09-2020, 09:51 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Here’s the latest: Compression with rockers in place: Cyl 1,2,3,4,5,7 = 0psi Cyl 6,8 = 300+psi (gauge doesn’t go higher than 300) I couldn’t...
    49 replies | 429 view(s)
  • grancito's Avatar
    08-09-2020, 08:09 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    When the lifter is in the back of the cam position, any force from the push rod, will overcome the weak spring in the lifter, and push the tiny...
    49 replies | 429 view(s)
  • CAdiesel's Avatar
    08-09-2020, 07:40 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    When I went to check compression I had 0psi on cyl 1. When I pulled the rocker assembly off I got about 180psi. So it appears that my valves are not...
    49 replies | 429 view(s)
  • grancito's Avatar
    08-09-2020, 07:33 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    I don't have the spec for the valves, only read it and didn't save it because I had new heads and block. The valve grind should not be a problem, as...
    49 replies | 429 view(s)
  • CAdiesel's Avatar
    08-09-2020, 07:07 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    10-4 on the starter. I lapped them by hand, in fact I had my kids help. (This has been a Covid project.) So let me know what “too much” is. I’d...
    49 replies | 429 view(s)
  • grancito's Avatar
    08-09-2020, 06:30 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    Yes you need the starter for a compression test. Hopefully you didn't lap the valves in a lot, the lifter tolerance is limited, but I can't remember...
    49 replies | 429 view(s)
  • CAdiesel's Avatar
    08-09-2020, 06:17 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I checked by putting aluminum foil over the intake ports and it seems all are pulling vacuum. So that’s a relief. I replaced one head completely...
    49 replies | 429 view(s)
  • grancito's Avatar
    08-09-2020, 05:21 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    It spins clockwise, the air out the intake sounds bad. There is an exhaust port on the intake side of each head, for S vin engines to recirculate...
    49 replies | 429 view(s)
  • CAdiesel's Avatar
    08-09-2020, 04:53 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    So I’ve turned over the motor by hand and checked each rocker. None are spongy. I cannot seem to spin any of the push rods by hand. Each rocker has...
    49 replies | 429 view(s)
  • grancito's Avatar
    08-09-2020, 03:43 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    You should be able to turn some of the push rods. Check if any push rods have up and down movement, push down on the rod end of the rocker to check...
    49 replies | 429 view(s)
  • CAdiesel's Avatar
    08-09-2020, 02:58 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Iíve got the valve covers off. What is the best way to turn over the motor to troubleshoot? Keeping in mind everything is disconnected. Also, should...
    49 replies | 429 view(s)
  • grancito's Avatar
    08-05-2020, 08:35 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    From memory, a bad crank sensor will give a no start, but the engine will start without it connected. When you said the engine turns over "not so...
    49 replies | 429 view(s)
  • CAdiesel's Avatar
    08-05-2020, 07:34 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I haven’t pulled the rocker covers yet. I’ve had to tend to other things. I did pull the ECM fuse to see what it would do without fuel. It turns over...
    49 replies | 429 view(s)
  • CAdiesel's Avatar
    08-02-2020, 01:05 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Okay, Thanks Grant. Ill let you know what I find out.
    49 replies | 429 view(s)
  • grancito's Avatar
    08-01-2020, 09:21 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    I have not heard of head differences causing a problem. Big job to remove the rocker covers, but I can't think of why it won't start. I have run mine...
    49 replies | 429 view(s)
  • CAdiesel's Avatar
    08-01-2020, 09:11 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I figured it was really unlikely. It’s the same starter as before the repairs. 10-4 on the injectors. I do have oil pressure while cranking, gauge...
    49 replies | 429 view(s)
  • grancito's Avatar
    08-01-2020, 02:35 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    It won't be cranking backwards unless you put a marine starter on it, designed for a counter rotating engine. I see no point in bleeding the last two...
    49 replies | 429 view(s)
  • CAdiesel's Avatar
    08-01-2020, 01:34 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    At this point I have cranked the motor to the point of having to charge the batteries several times and I don’t have any change. My next move is to...
    49 replies | 429 view(s)
  • CAdiesel's Avatar
    07-30-2020, 06:15 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Thanks Grant, I’ll update with any new developments.
    49 replies | 429 view(s)
  • grancito's Avatar
    07-29-2020, 06:36 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    Ok, so you should have oil pressure, unless the non return on the oil filter was faulty, I have had that, and the engine runs a while before getting...
    49 replies | 429 view(s)
  • CAdiesel's Avatar
    07-29-2020, 05:59 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I spun the oil pump with the motor in the stand until oil came out the galleys toward the top of the opening. It didn’t look like it would come out...
    49 replies | 429 view(s)
  • grancito's Avatar
    07-29-2020, 05:07 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    A video won't help diagnose the problem. I think I used a syringe to fill the new lifters, but they have to be removed, that is a huge job. New or...
    49 replies | 429 view(s)
More Activity