SSDieselSupply.com
SSDPro-Exhaust.com

Activity Stream

Filter
Sort By Time Show
Recent Recent Popular Popular Anytime Anytime Last 7 Days Last 7 Days Last 30 Days Last 30 Days All All Photos Photos Forum Forums Groups Groups
  • grancito's Avatar
    Yesterday, 10:48 PM
    I have one vehicle with a plug extension and the other hard wired, I drive in very hot conditions with no problem. A hood scoop could upset the air...
    1 replies | 14 view(s)
  • quvia1's Avatar
    06-15-2019, 06:54 PM
    Took My ambulance camper across country and had lots of issues mostly from heat. First my extension harness for my pmd kept heating the 6 prong...
    1 replies | 14 view(s)
  • grancito's Avatar
    06-12-2019, 04:58 PM
    You are right about what parts may be left off if someone else does the work. Taking the inner guard off, won't get you to the main bolts, but it...
    17 replies | 412 view(s)
  • RipnRun's Avatar
    06-12-2019, 01:44 PM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    I purchased the bracket and ARP 430-3511 starter bolts, If there aren't right I'll return them. I decided to take care of the starter myself,...
    17 replies | 412 view(s)
  • RipnRun's Avatar
    06-11-2019, 10:33 PM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    Thanks very much for the information, Grancito. I am tempted to take the wheel off and do the starter myself. I wonder what someone else might leave...
    17 replies | 412 view(s)
  • grancito's Avatar
    06-11-2019, 09:10 PM
    I measured the thread of the stud protruding from the starter, it is 6x1.25 mm and has to have a nut, the engine has a larger one, not sure if it is...
    17 replies | 412 view(s)
  • RipnRun's Avatar
    06-11-2019, 04:09 PM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    Thanks for the offer but I found one on Amazon. If you don't mind I have a few questions and a couple of pictures. I will order a new starter...
    17 replies | 412 view(s)
  • grancito's Avatar
    06-11-2019, 03:45 PM
    There is your problem of the broken bolt. The GMC truck I bought last, had just had the ring gear replaced, that made me suspicious, and right, it...
    17 replies | 412 view(s)
  • RipnRun's Avatar
    06-11-2019, 12:30 PM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    No support bracket.
    17 replies | 412 view(s)
  • RipnRun's Avatar
    06-11-2019, 10:30 AM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    Here is a possibly stupid question but remember that I'm not a mechanic: I looked up the bracket so that I know it's shape but, laying on the...
    17 replies | 412 view(s)
  • grancito's Avatar
    06-10-2019, 11:16 PM
    The starter will be fine. Does it have a bracket to the block on the other end? They need the bracket, the scum mechanics are too lazy to put it back...
    17 replies | 412 view(s)
  • RipnRun's Avatar
    06-10-2019, 10:43 PM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    Sorry I have been so long getting back. I twisted my back bad and I've been slowly getting caught up on work after being out of commission for a...
    17 replies | 412 view(s)
  • grancito's Avatar
    05-21-2019, 06:03 PM
    grancito replied to a thread Cracked Head in Engine
    Something must have gone wrong with the assembling of the water pump, I can't imagine a head gasket blown that bad. There will be water through the...
    5 replies | 212 view(s)
  • iRealty24's Avatar
    05-21-2019, 03:56 PM
    iRealty24 replied to a thread Cracked Head in Engine
    Thanks Grancito, I could only hear the water and see it on the dipstick so I guess I would have to say getting into the oil. I had no way of knowing...
    5 replies | 212 view(s)
  • grancito's Avatar
    05-17-2019, 02:05 PM
    grancito replied to a thread Cracked Head in Engine
    I am sill not clear on whether water gets into the oil or a cylinder when you squeeze the radiator hose. But to answer your question, remove the...
    5 replies | 212 view(s)
  • iRealty24's Avatar
    05-16-2019, 03:15 PM
    iRealty24 replied to a thread Cracked Head in Engine
    Thanks for your quick response. I thought I would get an email when someone responded so now I know I have to keep checking back. The engine was...
    5 replies | 212 view(s)
  • grancito's Avatar
    05-12-2019, 03:52 PM
    grancito replied to a thread Cracked Head in Engine
    I assume by water flowing into the engine, you mean into a cylinder. I is probably already seized. If you meant into the oil, then that will be the...
    5 replies | 212 view(s)
  • iRealty24's Avatar
    05-12-2019, 07:37 AM
    iRealty24 started a thread Cracked Head in Engine
    My 6.5 ran hot (multiple times) so I replaced the water pump. Not only did it run hot again, I could get water to flow into the engine by squeezing...
    5 replies | 212 view(s)
  • iRealty24's Avatar
    05-12-2019, 07:08 AM
    Larger Dually Wheels-----19.5 8-Lug Wheels Checking to see if anyone is running the 19.5 / 8-Lug Direct Bolt on wheels? I came across these and...
    0 replies | 116 view(s)
  • iRealty24's Avatar
    05-12-2019, 06:48 AM
    iRealty24 commented on iRealty24's photo in album Dually
    Wondering if anyone is running 19.5 Wheels/on their 1995/similar truck??
  • iRealty24's Avatar
    05-12-2019, 06:44 AM
    iRealty24 added 3 photo(s) to album Dually
  • iRealty24's Avatar
    05-12-2019, 06:42 AM
    iRealty24 created an album Dually
  • RipnRun's Avatar
    05-06-2019, 10:56 PM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    I do drive on salt roads. I'll give it a shot, thanks.
    17 replies | 412 view(s)
  • grancito's Avatar
    05-06-2019, 02:00 PM
    There is a possibility, if you drive on salt roads, that some has coated the surface of the heater and into the plug, thus causing a leak to ground....
    17 replies | 412 view(s)
  • RipnRun's Avatar
    05-06-2019, 09:07 AM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    Thanks, I'll try to get to it from the top.
    17 replies | 412 view(s)
  • grancito's Avatar
    05-05-2019, 03:22 PM
    I guess that you tested between the 2 pins on the plug, and yes the heater is working, but you need to test from one of the pins to ground (the...
    17 replies | 412 view(s)
  • RipnRun's Avatar
    05-04-2019, 06:33 PM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    I couldn't find a visible problem with the block heater cord. I couldn't get all the way to the block heater laying on my back in the driveway, lol, ...
    17 replies | 412 view(s)
  • RipnRun's Avatar
    04-30-2019, 10:58 AM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    Thanks, I'll check it out.
    17 replies | 412 view(s)
More Activity