SSDieselSupply.com
SSDPro-Exhaust.com

Activity Stream

Filter
Sort By Time Show
Recent Recent Popular Popular Anytime Anytime Last 7 Days Last 7 Days Last 30 Days Last 30 Days All All Photos Photos Forum Forums Groups Groups
  • grancito's Avatar
    05-21-2019, 06:03 PM
    grancito replied to a thread Cracked Head in Engine
    Something must have gone wrong with the assembling of the water pump, I can't imagine a head gasket blown that bad. There will be water through the...
    5 replies | 74 view(s)
  • iRealty24's Avatar
    05-21-2019, 03:56 PM
    iRealty24 replied to a thread Cracked Head in Engine
    Thanks Grancito, I could only hear the water and see it on the dipstick so I guess I would have to say getting into the oil. I had no way of knowing...
    5 replies | 74 view(s)
  • grancito's Avatar
    05-17-2019, 02:05 PM
    grancito replied to a thread Cracked Head in Engine
    I am sill not clear on whether water gets into the oil or a cylinder when you squeeze the radiator hose. But to answer your question, remove the...
    5 replies | 74 view(s)
  • iRealty24's Avatar
    05-16-2019, 03:15 PM
    iRealty24 replied to a thread Cracked Head in Engine
    Thanks for your quick response. I thought I would get an email when someone responded so now I know I have to keep checking back. The engine was...
    5 replies | 74 view(s)
  • grancito's Avatar
    05-12-2019, 03:52 PM
    grancito replied to a thread Cracked Head in Engine
    I assume by water flowing into the engine, you mean into a cylinder. I is probably already seized. If you meant into the oil, then that will be the...
    5 replies | 74 view(s)
  • iRealty24's Avatar
    05-12-2019, 07:37 AM
    iRealty24 started a thread Cracked Head in Engine
    My 6.5 ran hot (multiple times) so I replaced the water pump. Not only did it run hot again, I could get water to flow into the engine by squeezing...
    5 replies | 74 view(s)
  • iRealty24's Avatar
    05-12-2019, 07:08 AM
    Larger Dually Wheels-----19.5 8-Lug Wheels Checking to see if anyone is running the 19.5 / 8-Lug Direct Bolt on wheels? I came across these and...
    0 replies | 47 view(s)
  • iRealty24's Avatar
    05-12-2019, 06:48 AM
    iRealty24 commented on iRealty24's photo in album Dually
    Wondering if anyone is running 19.5 Wheels/on their 1995/similar truck??
  • iRealty24's Avatar
    05-12-2019, 06:44 AM
    iRealty24 added 3 photo(s) to album Dually
  • iRealty24's Avatar
    05-12-2019, 06:42 AM
    iRealty24 created an album Dually
  • RipnRun's Avatar
    05-06-2019, 10:56 PM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    I do drive on salt roads. I'll give it a shot, thanks.
    7 replies | 254 view(s)
  • grancito's Avatar
    05-06-2019, 02:00 PM
    There is a possibility, if you drive on salt roads, that some has coated the surface of the heater and into the plug, thus causing a leak to ground....
    7 replies | 254 view(s)
  • RipnRun's Avatar
    05-06-2019, 09:07 AM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    Thanks, I'll try to get to it from the top.
    7 replies | 254 view(s)
  • grancito's Avatar
    05-05-2019, 03:22 PM
    I guess that you tested between the 2 pins on the plug, and yes the heater is working, but you need to test from one of the pins to ground (the...
    7 replies | 254 view(s)
  • RipnRun's Avatar
    05-04-2019, 06:33 PM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    I couldn't find a visible problem with the block heater cord. I couldn't get all the way to the block heater laying on my back in the driveway, lol, ...
    7 replies | 254 view(s)
  • RipnRun's Avatar
    04-30-2019, 10:58 AM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    Thanks, I'll check it out.
    7 replies | 254 view(s)
  • grancito's Avatar
    04-29-2019, 11:13 AM
    Unplug the heater at the block, it pulls straight out but is tight, now connect the power, you may have damaged the cable when changing the battery....
    7 replies | 254 view(s)
  • RipnRun's Avatar
    04-28-2019, 10:10 PM
    I have been plugging my truck into the garage outlet for years with no problems. All of my garage and basement outlets are on one electric circuit,...
    7 replies | 254 view(s)
  • RipnRun's Avatar
    04-14-2019, 03:10 PM
    Never mind. Fixed
    0 replies | 169 view(s)
  • agb1758c's Avatar
    04-14-2019, 01:24 PM
    Your recirc door actuator needs to be replaced. It is a very common problem with Chevrolets. They run about 35.00 usd. Depending on the system you...
    3 replies | 2647 view(s)
  • RipnRun's Avatar
    04-06-2019, 11:45 PM
    I've never had a problem with the alternator regulator, but I'll keep that in mind, thanks.
    4 replies | 445 view(s)
  • RipnRun's Avatar
    04-06-2019, 11:35 PM
    Gone, sold I guess.
    0 replies | 139 view(s)
  • grancito's Avatar
    04-03-2019, 06:53 PM
    I have a spare in each vehicle and a spare alternator regulator in the suburban, the regulator was failing every 5,000 miles. The alternator has to...
    4 replies | 445 view(s)
  • RipnRun's Avatar
    04-03-2019, 12:12 PM
    Thanks for the info. I guess I'll just keep a spare in the truck.
    4 replies | 445 view(s)
  • agb1758c's Avatar
    03-29-2019, 10:20 PM
    agb1758c replied to a thread AM General 6.5 in Engine
    I noticed this thing will puff out a little white smoke on start up, on what I consider a warm morning about 65*F. Do you think this is normal or do...
    102 replies | 6925 view(s)
  • grancito's Avatar
    03-29-2019, 07:34 PM
    grancito replied to a thread AM General 6.5 in Engine
    Removing the shut off plunger is a good start, but the problem could be a bad connection somewhere or a chaffed wire shorting. Being intermittent...
    102 replies | 6925 view(s)
  • grancito's Avatar
    03-29-2019, 07:21 PM
    I hear that they usually suddenly die, and will sometimes work for a short distance after cooling down. But those were in the original place on the...
    4 replies | 445 view(s)
  • agb1758c's Avatar
    03-29-2019, 04:06 PM
    agb1758c replied to a thread AM General 6.5 in Engine
    Well here we go again! I have replaced my PMD with 3 different known good ones, replaced the extension harness with another new one. Drive around...
    102 replies | 6925 view(s)
More Activity