SSDieselSupply.com
SSDPro-Exhaust.com

Activity Stream

Filter
Sort By Time Show
Recent Recent Popular Popular Anytime Anytime Last 7 Days Last 7 Days Last 30 Days Last 30 Days All All Photos Photos Forum Forums Groups Groups
  • grancito's Avatar
    08-05-2020, 08:35 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    From memory, a bad crank sensor will give a no start, but the engine will start without it connected. When you said the engine turns over "not so...
    30 replies | 366 view(s)
  • CAdiesel's Avatar
    08-05-2020, 07:34 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I haven’t pulled the rocker covers yet. I’ve had to tend to other things. I did pull the ECM fuse to see what it would do without fuel. It turns over...
    30 replies | 366 view(s)
  • CAdiesel's Avatar
    08-02-2020, 01:05 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Okay, Thanks Grant. Ill let you know what I find out.
    30 replies | 366 view(s)
  • grancito's Avatar
    08-01-2020, 09:21 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    I have not heard of head differences causing a problem. Big job to remove the rocker covers, but I can't think of why it won't start. I have run mine...
    30 replies | 366 view(s)
  • CAdiesel's Avatar
    08-01-2020, 09:11 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I figured it was really unlikely. It’s the same starter as before the repairs. 10-4 on the injectors. I do have oil pressure while cranking, gauge...
    30 replies | 366 view(s)
  • grancito's Avatar
    08-01-2020, 02:35 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    It won't be cranking backwards unless you put a marine starter on it, designed for a counter rotating engine. I see no point in bleeding the last two...
    30 replies | 366 view(s)
  • CAdiesel's Avatar
    08-01-2020, 01:34 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    At this point I have cranked the motor to the point of having to charge the batteries several times and I don’t have any change. My next move is to...
    30 replies | 366 view(s)
  • CAdiesel's Avatar
    07-30-2020, 06:15 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Thanks Grant, I’ll update with any new developments.
    30 replies | 366 view(s)
  • grancito's Avatar
    07-29-2020, 06:36 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    Ok, so you should have oil pressure, unless the non return on the oil filter was faulty, I have had that, and the engine runs a while before getting...
    30 replies | 366 view(s)
  • CAdiesel's Avatar
    07-29-2020, 05:59 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I spun the oil pump with the motor in the stand until oil came out the galleys toward the top of the opening. It didn’t look like it would come out...
    30 replies | 366 view(s)
  • grancito's Avatar
    07-29-2020, 05:07 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    A video won't help diagnose the problem. I think I used a syringe to fill the new lifters, but they have to be removed, that is a huge job. New or...
    30 replies | 366 view(s)
  • CAdiesel's Avatar
    07-29-2020, 04:14 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I did replace the lifters. I soaked them in clean oil for weeks while I was waiting for parts. But then half of them sat in the motor for a few more...
    30 replies | 366 view(s)
  • grancito's Avatar
    07-29-2020, 02:38 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    Did you change the lifters? New ones need to be primed. I had a customers pickup in the workshop once, for 3 weeks, and the lifters bled the oil out,...
    30 replies | 366 view(s)
  • CAdiesel's Avatar
    07-29-2020, 12:06 AM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I only checked the timing chain tension when the oil pan was off. Seemed fine, not too much play, so I left it alone. I can’t imagine the glow plugs...
    30 replies | 366 view(s)
  • grancito's Avatar
    07-28-2020, 07:37 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    Did you replace the timing chain, if not, there should be no reason for a TDC relearn. I replaced the IP on the GMC truck and it has been running...
    30 replies | 366 view(s)
  • CAdiesel's Avatar
    07-28-2020, 03:02 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I did replace the motor mounts and I’m really putting them to the test. The shaking does seem like a timing issue. It’s rough but consistent. Is it...
    30 replies | 366 view(s)
  • grancito's Avatar
    07-28-2020, 02:09 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    The lock was really worn, it had too many keys swinging from it. The shaking could just be because of the limited number of cylinders firing. I can't...
    30 replies | 366 view(s)
  • CAdiesel's Avatar
    07-27-2020, 09:57 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I got the ignition lock replaced and now is working like new (key can’t be removed while running). Engine still cranks great and will stumble like it...
    30 replies | 366 view(s)
  • grancito's Avatar
    07-27-2020, 01:23 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    My suburban's ignition barrel did the same, I had to pull the ECM fuse to stop the engine. You have to remove the steering wheel to get to the...
    30 replies | 366 view(s)
  • CAdiesel's Avatar
    07-26-2020, 09:04 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I cranked it over and over until now the ignition lock won’t turn off. So I’ll be replacing that before trying again. I made sure to clean the...
    30 replies | 366 view(s)
  • grancito's Avatar
    07-25-2020, 10:08 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    They will start on 5 glow plugs, and run rough for half a minute, blowing white smoke then clatter with a big puff of black smoke. The vapour from...
    30 replies | 366 view(s)
  • CAdiesel's Avatar
    07-25-2020, 09:10 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    One new development since this morning... it appears I can prime the lift pump to about 5psi at the IP but without cycling the engine it will drop to...
    30 replies | 366 view(s)
  • CAdiesel's Avatar
    07-25-2020, 06:07 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Update: Even though I double checked (and it’s hard to mess up) I pulled the intake to check injector timing... Everything looks good there. ...
    30 replies | 366 view(s)
  • grancito's Avatar
    07-25-2020, 04:48 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    There is no need to bleed all of the injectors, 2 is enough. The glow plugs are needed on engines with poor compression, even when they are almost at...
    30 replies | 366 view(s)
  • CAdiesel's Avatar
    07-25-2020, 01:30 AM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I didn’t touch the bottom end when I had the motor out, just a visual inspection, and I left the IP alone, too. Just to be sure, I turned it over by...
    30 replies | 366 view(s)
  • grancito's Avatar
    07-25-2020, 12:25 AM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    Good you have fuel to the injectors. Next, are you getting enough glow plug time, 8 seconds? The other, is did you time the cam shaft correctly, and...
    30 replies | 366 view(s)
  • CAdiesel's Avatar
    07-24-2020, 11:58 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    So here it is, I’m able to jump the lift pump and hear it run. The motor cranks over pretty well and I loosened several injector lines to bleed any...
    30 replies | 366 view(s)
  • grancito's Avatar
    07-24-2020, 04:20 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    The shut off solenoid opens when the the ignition is on, have someone turn the key on and off and listen for the click or feel for it. You can remove...
    30 replies | 366 view(s)
  • CAdiesel's Avatar
    07-24-2020, 02:12 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Thanks Grant, I’ve now done that I have fuel pressure to the IP and the motor cranks but I’m not getting fuel to the injectors. I’m thinking maybe...
    30 replies | 366 view(s)
  • grancito's Avatar
    07-24-2020, 01:39 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    The system that year is a bad design, the pump does nothing until you operated the starter, or there is oil pressure. To get fuel through to the...
    30 replies | 366 view(s)
More Activity