SSDieselSupply.com
SSDPro-Exhaust.com

Activity Stream

Filter
Sort By Time Show
Recent Recent Popular Popular Anytime Anytime Last 7 Days Last 7 Days Last 30 Days Last 30 Days All All Photos Photos Forum Forums Groups Groups
  • quvia1's Avatar
    07-08-2019, 06:57 PM
    quvia1 replied to a thread Fuel leak under intake in Main Forum
    Glad I could help. You have always been a help to me.
    5 replies | 75 view(s)
  • grancito's Avatar
    07-08-2019, 04:43 PM
    grancito replied to a thread Fuel leak under intake in Main Forum
    That was good to find the leak without removing the manifold. Your leak made me check the fuel lines for the suburban, the engine is almost ready to...
    5 replies | 75 view(s)
  • quvia1's Avatar
    07-07-2019, 07:24 PM
    quvia1 replied to a thread Fuel leak under intake in Main Forum
    Found a small tear in the fuel line at bottom of filter housing. This wasn't the problem though. Replaced the line and started back up. Leak still...
    5 replies | 75 view(s)
  • quvia1's Avatar
    07-06-2019, 08:18 AM
    quvia1 replied to a thread Fuel leak under intake in Main Forum
    I,ll check out that]fuell filter hoses and o ring . It seem to be coming from that area. What bothers me it doesn't leak enough.to see while just...
    5 replies | 75 view(s)
  • grancito's Avatar
    07-05-2019, 11:03 PM
    grancito replied to a thread Fuel leak under intake in Main Forum
    You should be able to see a leak from the shutoff solenoid. I think the rubber fuel supply line runs under the manifold, I ran it above on the truck...
    5 replies | 75 view(s)
  • quvia1's Avatar
    07-05-2019, 08:06 PM
    Anyone ever have the fuel shutoff solenoid leak in their 6.5? I have a leak under the manifold and can't think of too much under there. It seems to...
    5 replies | 75 view(s)
  • grancito's Avatar
    06-26-2019, 04:25 PM
    Good, done right, and cheaper.
    23 replies | 663 view(s)
  • RipnRun's Avatar
    06-26-2019, 09:22 AM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    Starting like it should. Thanks again!
    23 replies | 663 view(s)
  • grancito's Avatar
    06-22-2019, 12:10 AM
    To send a photo, click advanced instead of reply, the photo has to be taken on low quality and usually needs to be cropped from a distant shot to...
    9 replies | 181 view(s)
  • quvia1's Avatar
    06-21-2019, 03:13 PM
    I am doing a rebuild of the air conditioner, condencer etc and system is empty. The condencer was clogged behind the two coolers but radiator was...
    9 replies | 181 view(s)
  • grancito's Avatar
    06-21-2019, 12:15 AM
    No, don't take it out, you will lose the gas, hose it out from behind.
    9 replies | 181 view(s)
  • quvia1's Avatar
    06-20-2019, 06:10 PM
    Thanks. Condencer comes out tomorrow an I will let you know
    9 replies | 181 view(s)
  • grancito's Avatar
    06-20-2019, 05:27 PM
    I am pleased to have been of some help, I hope it works OK.
    23 replies | 663 view(s)
  • RipnRun's Avatar
    06-20-2019, 05:01 PM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    I had a couple of hours to work on it today. Thanks to your advice, I was able to disconnect the two wires, remove the starter, and work the broken...
    23 replies | 663 view(s)
  • grancito's Avatar
    06-19-2019, 10:06 PM
    No problem for the radiator, but do you want hot air entering the cabin through the AC, plus posible oil fumes, and also oil vapour on the...
    9 replies | 181 view(s)
  • quvia1's Avatar
    06-19-2019, 04:41 PM
    Would it be an issue with the radiator if I put a hood vent facing the windshield ,hood scoop reversed, to let the hot air out?
    9 replies | 181 view(s)
  • grancito's Avatar
    06-18-2019, 08:33 AM
    Yes, could be the problem, I have the suburban apart, the AC condenser and the radiator look like a moth cemetery.
    9 replies | 181 view(s)
  • grancito's Avatar
    06-18-2019, 08:28 AM
    It is easier to unbolt the starter and drop it a bit, then undo the wires while working under the truck. That is the way I usually remove the...
    23 replies | 663 view(s)
  • RipnRun's Avatar
    06-17-2019, 07:13 PM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    I lost Saturday to installing new gutters out of town and couldn't work on the truck until this afternoon. The second bracket bolt is 8 x 1.25 20 mm...
    23 replies | 663 view(s)
  • quvia1's Avatar
    06-17-2019, 05:33 PM
    Every thing under the vehicle is stock. I will pull my air conditioner condencer out and replace it . I imagine it could be nasty behind it and...
    9 replies | 181 view(s)
  • grancito's Avatar
    06-16-2019, 10:48 PM
    I have one vehicle with a plug extension and the other hard wired, I drive in very hot conditions with no problem. A hood scoop could upset the air...
    9 replies | 181 view(s)
  • quvia1's Avatar
    06-15-2019, 06:54 PM
    Took My ambulance camper across country and had lots of issues mostly from heat. First my extension harness for my pmd kept heating the 6 prong...
    9 replies | 181 view(s)
  • grancito's Avatar
    06-12-2019, 04:58 PM
    You are right about what parts may be left off if someone else does the work. Taking the inner guard off, won't get you to the main bolts, but it...
    23 replies | 663 view(s)
  • RipnRun's Avatar
    06-12-2019, 01:44 PM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    I purchased the bracket and ARP 430-3511 starter bolts, If there aren't right I'll return them. I decided to take care of the starter myself,...
    23 replies | 663 view(s)
  • RipnRun's Avatar
    06-11-2019, 10:33 PM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    Thanks very much for the information, Grancito. I am tempted to take the wheel off and do the starter myself. I wonder what someone else might leave...
    23 replies | 663 view(s)
  • grancito's Avatar
    06-11-2019, 09:10 PM
    I measured the thread of the stud protruding from the starter, it is 6x1.25 mm and has to have a nut, the engine has a larger one, not sure if it is...
    23 replies | 663 view(s)
  • RipnRun's Avatar
    06-11-2019, 04:09 PM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    Thanks for the offer but I found one on Amazon. If you don't mind I have a few questions and a couple of pictures. I will order a new starter...
    23 replies | 663 view(s)
  • grancito's Avatar
    06-11-2019, 03:45 PM
    There is your problem of the broken bolt. The GMC truck I bought last, had just had the ring gear replaced, that made me suspicious, and right, it...
    23 replies | 663 view(s)
  • RipnRun's Avatar
    06-11-2019, 12:30 PM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    No support bracket.
    23 replies | 663 view(s)
  • RipnRun's Avatar
    06-11-2019, 10:30 AM
    RipnRun replied to a thread Weird electrical issue? in Main Forum
    Here is a possibly stupid question but remember that I'm not a mechanic: I looked up the bracket so that I know it's shape but, laying on the...
    23 replies | 663 view(s)
More Activity