SSDieselSupply.com
SSDPro-Exhaust.com

Activity Stream

Filter
Sort By Time Show
Recent Recent Popular Popular Anytime Anytime Last 7 Days Last 7 Days Last 30 Days Last 30 Days All All Photos Photos Forum Forums Groups Groups
Filter by: Forums Clear All
  • quvia1's Avatar
    09-17-2017, 07:37 PM
    quvia1 replied to a thread PMD extension cable,, in Main Forum
    my extension cable went last year. If I wiggled it near the connection the truck would start. One of the connectors pulled out of the plug. It took a...
    2 replies | 71 view(s)
  • grancito's Avatar
    09-15-2017, 02:45 AM
    grancito replied to a thread PMD extension cable,, in Main Forum
    I have a home made one 8 years old on the suburban and a bought 3 year old one on the 95 GMC . No problems. Only posible failure point would be water...
    2 replies | 71 view(s)
  • 94GMC2500's Avatar
    09-06-2017, 01:08 AM
    Are these extension cables known for going bad? I am having stalling and not starting problems and I think the cable that is bad. The cable is...
    2 replies | 71 view(s)
  • agb1758c's Avatar
    07-27-2017, 06:54 PM
    agb1758c replied to a thread AM General 6.5 in Engine
    I'm going to pull it out this weekend and get the motor opened up and check. I agree, back in the 80s I had a 80 Impala and on weekends rebuild...
    10 replies | 323 view(s)
  • grancito's Avatar
    07-27-2017, 02:37 PM
    grancito replied to a thread AM General 6.5 in Engine
    That scoring won't cause a problem, but if the other crank is better, you should use it. The engine out and in process is a pain, where are the easy...
    10 replies | 323 view(s)
  • agb1758c's Avatar
    07-26-2017, 11:34 PM
    agb1758c replied to a thread AM General 6.5 in Engine
    I think I may have found a problem today. If you look at the picture of the crank rod journal, you can see some slight grooving. After cleaning up...
    10 replies | 323 view(s)
  • grancito's Avatar
    07-26-2017, 09:03 PM
    grancito replied to a thread AM General 6.5 in Engine
    All looks good, I just put STD bearings in recommended but you were lucky to find the .013 undersize. but mine is a bastard engine.
    10 replies | 323 view(s)
  • agb1758c's Avatar
    07-26-2017, 12:07 AM
    agb1758c replied to a thread AM General 6.5 in Engine
    Looks like everything will go back in like it came out. The red on the bearings was the reflection from my shop. The uppers will be going back in...
    10 replies | 323 view(s)
  • grancito's Avatar
    07-24-2017, 04:22 PM
    grancito replied to a thread AM General 6.5 in Engine
    The bearings look good. There is a red light shining on them that makes it look like the lead has gone in parts and the copper is showing. Check the...
    10 replies | 323 view(s)
  • agb1758c's Avatar
    07-24-2017, 11:28 AM
    agb1758c replied to a thread AM General 6.5 in Engine
    I was wondering about the main bolts. I didn't get a chance to check things out yesterday. As soon as I can I will get the pictures posted for you...
    10 replies | 323 view(s)
  • grancito's Avatar
    07-23-2017, 03:34 PM
    grancito replied to a thread AM General 6.5 in Engine
    Cylinder 7 is the one that cracked in my engine, it and 8 heat up the most. Any signs of bore scoring on 7? I would pull that piston to check for...
    10 replies | 323 view(s)
  • agb1758c's Avatar
    07-23-2017, 12:01 AM
    agb1758c replied to a thread AM General 6.5 in Engine
    I had the block upside down to inspect lower end and when I turned it back over noticed oil seeping around the rings on #7. The top of the piston...
    10 replies | 323 view(s)
  • grancito's Avatar
    07-22-2017, 12:47 AM
    grancito replied to a thread AM General 6.5 in Engine
    It sounds like it has recently been rebuilt. Check really well the heads and rear cylinders for cracks, then put it back together. Cracks kill these...
    10 replies | 323 view(s)
  • agb1758c's Avatar
    07-21-2017, 12:34 AM
    agb1758c started a thread AM General 6.5 in Engine
    Long story short, 18 months ago I bought a AM General 6.5 N.A. Of course it shows up the day after I have surgery. Finally got the chance to open...
    10 replies | 323 view(s)
  • MrMarty51's Avatar
    06-25-2017, 10:21 PM
    Yeah, I was hoping it would help the mileage, now getting 16 to the gallon. Wifey and I was going to church this morning, driving about 78 mph,...
    4 replies | 233 view(s)
  • grancito's Avatar
    06-25-2017, 08:36 PM
    The mechanical waste gate control is good, but it drops my mpg by one mile, boost is too high at low throttle, 3 1/2 psi instead of 1 1/2 at 60 mph.
    4 replies | 233 view(s)
No More Results