PDA

View Full Version : Please Help Won't start



blowfishct
12-28-2007, 05:23 PM
I have a 1994 GMC 6.5l Turbo. It ran fine no problems. And then nothing I turned the key on and the dash lights came on the only light that did not come on was the glow plug light and then the glow pulg switch clicked and nothing all the lights went out!! It's like some unhooked the battery turn the key off and the same thing. I thought the starter was bad and repaced it and that was not it. I trided to unhook the glow plug switch and still nothing. All the fuses are good i just dont know. Thanks.

DieselFreak
12-28-2007, 06:13 PM
A few months after I got my truck, I had the very same problem. Also replaced stater, as I thought it to be bad. Glow plugs were old and had many milles on them, so I replaced them.
Problem was still there... Replaced ignition key wiring harness, as I was told this could be an issue.
Seemed to fix the problem - haven't had it since.

What caused the actual problem, I don't know. This is what have been replaced, and the problem is gone.

Hope it helped a bit :-)

blowfishct
12-28-2007, 06:20 PM
did you get the part from a dealer?

Chevylover
12-29-2007, 05:40 AM
As you descirbed your problem, i would suppose, that your ignition switch could be the one who's making the problem.


Cu,
Sven

blowfishct
12-29-2007, 04:29 PM
I went to the local GMC place today and they said that it was the ingition block under the Column its a $28.00 part from them. I did not get it yet but I went back to my shop and it started up :eek: after 2 days siting it just started.

DieselFreak
12-29-2007, 06:36 PM
Yes kinda.... Local mechanic buys it somewhere of someone who imports GMparts from the US...

The ignition block is also what I think was the issue.