PDA

View Full Version : Won't start...will start....won't start



agb1758c
03-21-2010, 06:42 PM
I am looking for any suggestions that you people might have. I started my truck, backed out the drive and it died. It would crank, didn't get the glow plug light and wouldn't start. Changed out the PMD with spare, nothing, checked for fuel, plenty, changed out fuel shutdown solinoid, Started. Ran fine for about a month, then this morning would crank but not start, didn't get the glow plug light, changed PMD, FSS, checked plug on ignition switch and nothing. Got new Glow plug controller...nothing. Found a GM Security System, disconnected it and redid the wires still nothing. Got mad, went to work for a few hours, then to store. Got home went back to truck, turned key glow plug light came on for a second,doors locked, would crank but not start. Tried it again, glow plug light for about 4 seconds, doors locked, would crank, still nothing. Tried again, doors locked, glow plug light came on for 8-10 seconds fired right up. Running like new. The doors would periodically lock but not all the time. Any ideas?

oldyeller6.5
03-03-2011, 12:46 PM
a short between your batteries and IP, or a plugged fuel filter... but i'm not sure.. mine is all mechanical and stalls like that sometimes... cuz of fuel starvtion cuz my lift pump is out

Racer5551
03-07-2011, 04:12 PM
Ignition switch failed.

Suburban K2500 HD
03-07-2011, 05:36 PM
Have you checked all the Ground points, wery important to have good ground.
At IP black wire, At right rear of engine head, and bateries..

newdieselguy
05-07-2011, 08:47 AM
I had the same issue for about a year. I finally relocated the PMD with a heat sync behind the grill and all was good for a month. Then same ol same ol. I then relocated the relocated PMD to the driver side fender and it was then that i could put my finger on the connector to the PMD and make the truck stumble. So 2 wire ties later and problem solved hasnt stalled or stumbled even once for the last 2 weeks.

trukdoc
05-07-2011, 11:20 AM
...locks STILL work without your control,then you don't have all of the factory security system unhooked...a short in THIS system is causing your problems...wrong signal to system initiated a no-start to stop thieves...