PDA

View Full Version : No glow plug light



grancito
11-22-2012, 04:36 PM
I have no glow plug light, code #29 (glow plug relay fault). The relay is functioning, also the glow plugs. Fuses in the cab are OK. I found a circiut diagram from this site for a 96, that shows a fuse in the engine compartment, between the left side glow plugs and the connection to the light and ECM. Anyone know where the fuse is for a 1994?

Ohio6.5Dually
11-22-2012, 08:25 PM
could the bulb just be blown out? if it is i just got a whole bunch of twist base bulbs way too many for what i need so let me know.

grancito
11-22-2012, 09:16 PM
Thanks for the offer, I forgot to say that the bulb is OK and I've cleaned and retensioned the contacts at the back of the instrument panel. I'm sure that the problem is in the engine compartment, but don't want to pull the wiring loom apart.

JD_countryboy
12-09-2012, 10:01 PM
Not sure if this will help you, or if your fixed already. I do know on my 93 that the dash light is powered from the wire harness going to the glow plugs from the power out post of glow plug relay. if and where a fuse would be i don't know. My glow plugs are hooked up manualy thru a simple solenoid, not the factory relay anymore, and the dash light works as it should.

grancito
12-09-2012, 11:28 PM
After a lot of searching on google, I found that there is a fuse bottom right, 5 amp on the fuse block inside the cab. Mine has no power when the glow plugs are on. Then next time I went to start it the light came on, since then no. So the connection through the plug in the fire wall is bad, and there is one each side of the engine compartment, with about 50 wires in each, perhaps the connection in the loom where that wire connects to where the left side glow plug wires divide from 1 to 4 is bad. I am not going to pull the loom apart. Will eventually run a new wire from the relay to the fuse box.