PDA

View Full Version : Engine wont stop rolling over!!



99C2500
04-28-2007, 01:33 PM
I have two problems:

I had to pull a battery cable to get it to stop, first I tried removing the starter relay but it kept rolling over. Where do I begin with this one ?

Next problem:

Engine won't start because of a bad lift pump (I think).Changed the filter/seperator yesterday and the old filter was only black on the first inch of filter material.I ran a jumper from a 12v source to the pump relay got under the truck and could here the pump working and then opened the bleeder on the filter and there is nothing coming out. While all of this was going on the engine roll over problem started. Should I open the fuel lines at the filter to confirm a bad lift pump ? Is there something between the lift pump and filter housing that could be the problem ?

P.S.
truck was running before I changed the filter

Thanks

sixnickel
04-28-2007, 06:16 PM
I am guessing this truck is a 99 by your sign on name. How did you hot wire the lift pump?? Tell me what you did exactly, where did you get the 12v and how did you energize the lift pump?? If it is a 99 it's real easy to hot wire the lift pump. You have a fuse /relay box on the left inner fender by the master cylinder. Coming out the back toward the firewall is a large wire loom, about 3 or 4" from the box is a pigtail breaking out of the loom. This is a hot wire to the lift pump. Put 12v to this wire and the lift pump will run if it is good. The lift pump relay must be installed though. If you were cranking a lot to try to start the engine the batteries could be down. This can cause the contacts in the starter solenoid to weld themselves together sometimes. If you rap the starter and solenoid with a hammer a few times this might open the contacts. If you have a battery charger put it on it!! Why did you change the fuel for PM or did you have a problem??

99C2500
04-28-2007, 08:13 PM
I used a piece of wire from one of the Aux 12v connections to the #30 connection on the relay pump after removing the relay. I changed the filter because I had minor surging at 60 mph and assumed it was a dirty filter . Yes I did a lot of cranking and the batteries are down. Luck as it that my charger is about 60 miles from my house right now at my fathers place. Thanks for advice on how to jump the lift pump and the starter solenoid hammer advice.

""Why did you change the fuel for PM or did you have a problem??""

PM ??? Sorry not familiar with this one

I changed my PMD in early January 07
I'm also wondering if a pin hole in my fuel line could be the problem.

Thanks for the reply

sixnickel
04-28-2007, 08:41 PM
PM =preventive maintenance PMS= preventive maintenance service

nathan
05-05-2007, 06:23 PM
yes a pin hole in the line before the pickup pump could defenetly be the problem. usually if the pump runs it is good.