SSDieselSupply.com
SSDPro-Exhaust.com
Tab Content
  • CAdiesel's Avatar
    10-16-2020, 01:57 PM
    Huh. ‘95s have a cable that runs through the cab. Wouldn’t have guessed. Any thoughts why they did that? Sorry to hear about the HOA. MinE is still...
    10 replies | 187 view(s)
  • CAdiesel's Avatar
    10-07-2020, 01:34 PM
    No cable, its all linkage to trans. You may be able to disconnect linkage to see if it is in fact in the trans or steering column.
    10 replies | 187 view(s)
  • CAdiesel's Avatar
    08-31-2020, 04:40 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I saw no “smoking gun” that would keep the lifters from adjusting, although the piston inside was a little difficult to get out of a couple of them....
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-31-2020, 12:50 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I have finally gotten around to pulling one head (drivers side) and all the lifters. (I’ll do the other one later.) I was only able to compress two...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-14-2020, 05:38 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Never worked on ‘60s Chev, that sounds like a messy job, yikes! I think you’re right with pulling a lifter. I’m going to wait until it cools off a...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-14-2020, 11:37 AM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Ill give it a shot. One more thing, I cranked the motor over for about 25-30 seconds, without the valve covers on. By the time I had pressure at the...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-13-2020, 10:40 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I’m looking at .923 and I didn’t see anything funky when I put the new ones in. I have to admit I didn’t even think to look if they were different...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-13-2020, 08:02 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I kept one lifter and I have a mic (but its in inches) what measurement are we looking at?
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-10-2020, 10:32 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Thanks Grant. I’ve been in contact with Walt. He’s been really helpful. I’ll let you know what I find out. All indications point to the lifters not...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-10-2020, 01:29 AM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    It’s a worthwhile question... yes I did. I’ve been thinking about it a lot and what has changed during rebuild, considering it did run before I...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-09-2020, 11:17 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    All the push rods on the drivers side are the same length as the old one I kept. I’ll pull the passenger side out tomorrow and check them. I...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-09-2020, 09:51 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Here’s the latest: Compression with rockers in place: Cyl 1,2,3,4,5,7 = 0psi Cyl 6,8 = 300+psi (gauge doesn’t go higher than 300) I couldn’t...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-09-2020, 07:40 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    When I went to check compression I had 0psi on cyl 1. When I pulled the rocker assembly off I got about 180psi. So it appears that my valves are not...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-09-2020, 07:07 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    10-4 on the starter. I lapped them by hand, in fact I had my kids help. (This has been a Covid project.) So let me know what “too much” is. I’d...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-09-2020, 06:17 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I checked by putting aluminum foil over the intake ports and it seems all are pulling vacuum. So that’s a relief. I replaced one head completely...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-09-2020, 04:53 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    So I’ve turned over the motor by hand and checked each rocker. None are spongy. I cannot seem to spin any of the push rods by hand. Each rocker has...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-09-2020, 02:58 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Iíve got the valve covers off. What is the best way to turn over the motor to troubleshoot? Keeping in mind everything is disconnected. Also, should...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-05-2020, 07:34 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I haven’t pulled the rocker covers yet. I’ve had to tend to other things. I did pull the ECM fuse to see what it would do without fuel. It turns over...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-02-2020, 01:05 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Okay, Thanks Grant. Ill let you know what I find out.
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-01-2020, 09:11 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I figured it was really unlikely. It’s the same starter as before the repairs. 10-4 on the injectors. I do have oil pressure while cranking, gauge...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    08-01-2020, 01:34 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    At this point I have cranked the motor to the point of having to charge the batteries several times and I don’t have any change. My next move is to...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    07-30-2020, 06:15 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Thanks Grant, I’ll update with any new developments.
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    07-29-2020, 05:59 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I spun the oil pump with the motor in the stand until oil came out the galleys toward the top of the opening. It didn’t look like it would come out...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    07-29-2020, 04:14 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I did replace the lifters. I soaked them in clean oil for weeks while I was waiting for parts. But then half of them sat in the motor for a few more...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    07-29-2020, 12:06 AM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I only checked the timing chain tension when the oil pan was off. Seemed fine, not too much play, so I left it alone. I can’t imagine the glow plugs...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    07-28-2020, 03:02 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I did replace the motor mounts and I’m really putting them to the test. The shaking does seem like a timing issue. It’s rough but consistent. Is it...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    07-27-2020, 09:57 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I got the ignition lock replaced and now is working like new (key can’t be removed while running). Engine still cranks great and will stumble like it...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    07-26-2020, 09:04 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    I cranked it over and over until now the ignition lock won’t turn off. So I’ll be replacing that before trying again. I made sure to clean the...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    07-25-2020, 09:10 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    One new development since this morning... it appears I can prime the lift pump to about 5psi at the IP but without cycling the engine it will drop to...
    61 replies | 1731 view(s)
  • CAdiesel's Avatar
    07-25-2020, 06:07 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Update: Even though I double checked (and it’s hard to mess up) I pulled the intake to check injector timing... Everything looks good there. ...
    61 replies | 1731 view(s)
More Activity

Statistics


Total Posts
Total Posts
196
Posts Per Day
0.05
General Information
Last Activity
10-16-2020 01:57 PM
Join Date
03-08-2009
Referrals
0