SSDieselSupply.com
SSDPro-Exhaust.com
Tab Content
  • CAdiesel's Avatar
    01-08-2021, 02:29 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Ok, thanks Grant. I'll keep an eye on it.
    73 replies | 3923 view(s)
  • CAdiesel's Avatar
    01-07-2021, 06:35 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    So this is what I know at this point... The volt gauge hasn't worked in the 11 or so years that I have owned the truck. In that time I have replaced...
    73 replies | 3923 view(s)
  • CAdiesel's Avatar
    12-29-2020, 11:37 AM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    10-4 on the speed sensor. I’m taking the truck to a trans shop to get it the once over anyway but I’ll keep that in mind. Are you saying that the...
    73 replies | 3923 view(s)
  • CAdiesel's Avatar
    12-27-2020, 11:10 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Speedo seemed to work ok but was a little bouncy. Sub sat for almost 4 years before I tore it apart this spring. It did run but I didn't want to push...
    73 replies | 3923 view(s)
  • CAdiesel's Avatar
    12-27-2020, 05:43 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Took Sub for a drive and it seems that the trans reset and I have all 4 gears... for now. Thanks for the reminder that although the SES light...
    73 replies | 3923 view(s)
  • CAdiesel's Avatar
    12-26-2020, 02:04 PM
    CAdiesel replied to a thread Troubleshooting Lift Pump in Engine
    Finally got it running about 6 weeks ago, then left town for about a month. Here's what it took: I replaced the new lifters and had no change. So...
    73 replies | 3923 view(s)
No More Results

Statistics


Total Posts
Total Posts
202
Posts Per Day
0.05
General Information
Last Activity
Today 01:02 PM
Join Date
03-08-2009
Referrals
0