SSDieselSupply.com
SSDPro-Exhaust.com
Tab Content
  • grancito's Avatar
    01-07-2021, 10:13 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    I'm just back from a 8 hour drive, some in the dark, and no gauge problem this time. I don't understand how the IP sees the cylinder imbalance....
    73 replies | 3923 view(s)
  • grancito's Avatar
    01-03-2021, 11:44 AM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    Let me know if you find the problem. I went on long drive yesterday, and 1 hour from home at night, the volt meter was reading very low, I guessed it...
    73 replies | 3923 view(s)
  • grancito's Avatar
    01-01-2021, 10:22 AM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    The gauge may have failed, the signal comes from the ignition switch circuit, so I am guessing that the gauge failed, because a break from there to...
    73 replies | 3923 view(s)
  • grancito's Avatar
    12-28-2020, 09:04 AM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    Sounds like a connection problem on the speed sensor, check for that, and if you buy a new one, rockauto sells one with a new plug wired and heat...
    73 replies | 3923 view(s)
  • grancito's Avatar
    12-27-2020, 08:59 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    The starting price for the sensor is $8 so no great cost if it isn't the problem. The speedometer should be using the same sensor, so it should have...
    73 replies | 3923 view(s)
  • grancito's Avatar
    12-26-2020, 05:06 PM
    grancito replied to a thread Troubleshooting Lift Pump in Engine
    Hell, you are not having much luck. My transmission in the 95 truck went into 1st gear only mode a few years ago, when I was 6 hours from home, and I...
    73 replies | 3923 view(s)
  • grancito's Avatar
    11-28-2020, 04:14 PM
    Ok, good to fix it the right way.
    17 replies | 1256 view(s)
  • grancito's Avatar
    10-26-2020, 07:27 PM
    I have an idea, I have been working on my house water pump, the pipe connections had the leaks sealed with wraps of tire inner tube, common repair...
    17 replies | 1256 view(s)
  • grancito's Avatar
    10-21-2020, 02:49 PM
    You could put some epoxy on the ball to make it bigger, after fitting the cable end, or force a piece of plastic hose over it. A new cable from...
    17 replies | 1256 view(s)
  • grancito's Avatar
    10-21-2020, 01:07 AM
    I had a look, and the plastic end must be clipped over a ball, it looks like the end unclips from the cable, but the end is not sold separate. I...
    17 replies | 1256 view(s)
  • grancito's Avatar
    10-19-2020, 02:33 AM
    Good news. I'll look at the connection on mine in a day or two, to see what can be done.
    17 replies | 1256 view(s)
No More Results

3 Visitor Messages

  1. View Conversation
    thanks 4 info
  2. View Conversation
    hey man can u tell me what my trany temp. should run at normal and high thanks
  3. View Conversation
    i put a boost control switch on mine the switch that is mounted on the intake i think thats what it is called and wow mine is running like a new truck no smoke at all now thanxs for all the help thanxs scott
Showing Visitor Messages 1 to 3 of 3
About grancito

Basic Information

About grancito
Biography:
Retired engineering and auto repairer
Interests:
making things, mainly from steel, fishing, or just getting out boating
Occupation:
watching the bay for good weather to go out there
Year:
1994
Make:
GMC
Model:
2500 HD suburban 4X4 auto
Mileage:
150,000-249,999
Modifications:
#9 resistor, manual waste gate
Other Trucks:
1982 Chev silverado diesel 1/2 ton 4X4 short bed
1995 6.5 turbo diesel Gmc 4x4 extra cab long bed

Signature


Grant H.
1995 6.5 turbo GMC K2500 extra cab 4x4 pickup, PMD under bumper, mechanical wastegate, 228,000 miles, rebuilt engine, 4.10 diff, 16 mpg
1994 6.5 turbo GMC K2500 4x4 suburban #9 resistor, PMD in the bumper, mechanical waste gate, 226,000 miles, 3.73 diff, 16 mpg
1982 4x4 shortbed 6.2 Chev 260,000 miles untouched motor 17 MPG 4.27 diff. Best thing I ever owned, since 1992.

Statistics


Total Posts
Total Posts
2,940
Posts Per Day
0.58
Visitor Messages
Total Messages
3
Most Recent Message
10-23-2011 06:21 PM
General Information
Last Activity
Today 04:44 PM
Join Date
02-16-2007
Referrals
0

1 Friend

  1. kustomizer kustomizer is offline

    Junior Member

    kustomizer
Showing Friends 1 to 1 of 1