SSDieselSupply.com
SSDPro-Exhaust.com
Results 1 to 5 of 5

Thread: Failed pmd already?

  1. #1

    Default Failed pmd already?

    I replaced the pmd christmas time last year on ssdiesels heatsink...and the other day truck started acting up, it would rev up at idle but like it was dumping in to much fuel because it would shoot out a fair amount of black smoke. That started then it went away for a day or two now its back...now ill be driving down the road and it will die out for 2-3 seconds then come back. Then for the first time it stalled while pulling into a parking lot, but started right back up. I've retourqed the screws on the pmd at every oil change. I did have a code 51 (PROM error) but I reset codes and it hasnt reappered. PMD goin out again?
    1995 K2500 HD (F) vin - 201000 miles, 4.10 diff, turbomaster "fresh rebuilt" motor, Marine injectors, #9 resistor, straight piped, stacks, custom paint, 4" lift, 35's

  2. #2
    Join Date
    Nov 2007
    Location
    Weatherford,Tx
    Posts
    154

    Default

    did you apply the heatsink compound to the back of the pmd when you installed it.
    96 GMC C1500 SUBURBAN 2WD,VIN F,restrictor removed and inlet opened.SSDIESEL PMD and heatsink.soon to have gauges and
    exhaust.

  3. #3

    Default

    it was pre installed from ssdiesel...but its the pmd...it stalled last night and wouldnt re start...jumped out and pluged in my old pmd and fire right up...
    1995 K2500 HD (F) vin - 201000 miles, 4.10 diff, turbomaster "fresh rebuilt" motor, Marine injectors, #9 resistor, straight piped, stacks, custom paint, 4" lift, 35's

  4. #4
    Join Date
    Nov 2007
    Location
    Weatherford,Tx
    Posts
    154

    Default

    That sucks,but if you installed it a christmas,and bought it with the heat sink,should have warranty on it(1 yr.)give ssd a call.I have had mine on for about two years,no problems.
    96 GMC C1500 SUBURBAN 2WD,VIN F,restrictor removed and inlet opened.SSDIESEL PMD and heatsink.soon to have gauges and
    exhaust.

  5. #5
    Join Date
    Sep 2007
    Posts
    372

    Default

    I had a similar problem because I installed the heatsync / PMD where SSDiesel said to put it. Maybe this is what you did too? I bought a new pmd and moved the heat Sync / Pmd to the bumper hole and have not had an issue since.
    1997 Silverado 1500 6.5. with 200,000 miles. New fuel injection pump at 132,000 mi. FSD Heat-Sync in bumper hole, marine fuel injectors, air induction kit all from Walt at 148,000 mi. Replaced OEM Fuel Filter Assy, wastegate solenoid valve, OPS and relay at 155,000 mi. Harmonic Balancer replaced. Red dot and White dot EGR replaced. New starter, Instant Heat glow plugs, and glow plug relay/controller at 180,000. Replaced hydroboost and master cylinder in 2016. New Interstate batteries 4/13/19.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •