SSDieselSupply.com
SSDPro-Exhaust.com
Results 1 to 3 of 3

Thread: Code 29-Glow plug relay fault

  1. #1
    Join Date
    Nov 2010
    Location
    Nashville
    Posts
    54

    Default Code 29-Glow plug relay fault

    I started my truck cold after setting several days and this was only code that came up and I had a PMD issue at the same time. Read the site and saw where several reported that this code 29 could be something of an anomaly that was hard to identify. Another PMD, running OK & the code reset twice. So started searching the relay. The main power wire to relay stud under the boot was corroded and not even finger tight with star washer corroded. It is the original unit and has never been touched. The output side of the relay was also loose though not as bad. Cleaned, tightened and dielectric grease and problem solved. So moral is that the Code 29 was real but seemed to be coincidental. Thought that I would share for the braintrust. Still have a PMD issue with a new PMD that quits. After three or four start and drives and then will restart and NO codes set. It appears to be the new PMD and will put it back to the old reliable pump mounted 34583 that seems to be the reliable backup and the only one I am starting to have confidence in. Will stay after it and let Ya'll know.
    95 K2500 Suburban, orig owner, 101000 miles,F vin, Banks Stinger system in 2000 (EGT & Boost gages,air intake,K&N,chip), CAT reqd here, 3.73 posi, 4L80E w/mercon V semisynthetic, Flight Systems remote PMD (#9 res), new IP @78,000 under warranty,SSD cooling sys w/ Dmax fan upgrade @95600 and all new hoses. New main pulley & Fluidamper @99200. PMDCable extension to bumper @ 101000. Walbro FR pump w/prefilter. FloPro Crossover. Diamond Eye 4" exhaust and high flow CAT

  2. #2
    Join Date
    Oct 2010
    Location
    Scugog Island Ontario Canada
    Posts
    203

    Default

    I see flight systems PMD in your sig,is that the brand that is new and failing or a grey stanadyne?

  3. #3
    Join Date
    Nov 2010
    Location
    Nashville
    Posts
    54

    Default

    The DTech did fail, about three days out of warranty. Dipaco honored the warranty. They said that my serial number batch had experienced an above average failure rate. I have a new Flight Systems that is so far doing fine. I revised my remote location to in front of the battery with heat sink turned to the air hole in the core support and I have checked it several times and the heat sink is always cool to the touch. I have not been positive about the bumper location for several reasons so thought I will run it as described and plan on putting in a Stainless separator in case of any battery acid leaks and to get it further isolated from engine compartment.
    95 K2500 Suburban, orig owner, 101000 miles,F vin, Banks Stinger system in 2000 (EGT & Boost gages,air intake,K&N,chip), CAT reqd here, 3.73 posi, 4L80E w/mercon V semisynthetic, Flight Systems remote PMD (#9 res), new IP @78,000 under warranty,SSD cooling sys w/ Dmax fan upgrade @95600 and all new hoses. New main pulley & Fluidamper @99200. PMDCable extension to bumper @ 101000. Walbro FR pump w/prefilter. FloPro Crossover. Diamond Eye 4" exhaust and high flow CAT

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •