SSDieselSupply.com
SSDPro-Exhaust.com
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Problem with hvac system

  1. #1
    Join Date
    Jan 2012
    Posts
    1

    Default Problem with hvac system

    I'm having a problem with my hvac system. When ever I turn on the blower motor it only blows to the floor. It doesn't matter what positions I put the switch in it only blows on the floor. Any ideas ????

  2. #2
    Join Date
    Oct 2010
    Location
    Scugog Island Ontario Canada
    Posts
    203

    Default

    Have a look at the actuator lever that is mounted on the HVAC box beside the steering column up fairly high,the wind from the blower used to blow mine off sometimes,a dab of silicone in the hole and press it back on the shaft solved the problem.

  3. #3
    Join Date
    Jun 2008
    Location
    Burnet durnet Tx
    Posts
    911

    Default

    what year? if it has the electronic head,might as well start calling wrecking yards
    ..93 3500HD 200h 4L80E 4.88..11150lbs allatime..88 c.c. dually..6.2..auto w/doug nash 2-sp..camo paint...58 A120 4by IH{old vfd brush trk} 71ford p/u 79 shovel {{{ hooorraaayyy the bus is gone}}} 93 2500 parts truk {gone to that great chrusher in the sky 01 burban{wifes'.."no you can't use mine"}

  4. #4
    Join Date
    Sep 2007
    Posts
    329

    Default

    I have a similar problem. I can get the air blowing to the defrost or floor but directly at me takes 2-10 minutes to open the vents. Do 1997's have the electronic part?
    1997 Silverado 1500 6.5. with 185,000 miles. New fuel injection pump at 132,000 mi. FSD Heat-Sync in bumper hole, marine fuel injectors, air induction kit all from Walt at 148,000 mi. Replaced OEM Fuel Filter Assy, wastegate solenoid valve, OPS and relay at 155,000 mi. Harmonic Balancer replaced. Red dot and White dot EGR replaced. New starter, Instant Heat glow plugs, and glow plug relay/controller at 180,000. Replaced hydroboost and master cylinder in 2016.

  5. #5
    Join Date
    Jun 2008
    Location
    Burnet durnet Tx
    Posts
    911

    Default

    88 up oh right this post is toooo short
    ..93 3500HD 200h 4L80E 4.88..11150lbs allatime..88 c.c. dually..6.2..auto w/doug nash 2-sp..camo paint...58 A120 4by IH{old vfd brush trk} 71ford p/u 79 shovel {{{ hooorraaayyy the bus is gone}}} 93 2500 parts truk {gone to that great chrusher in the sky 01 burban{wifes'.."no you can't use mine"}

  6. #6
    Join Date
    Jul 2012
    Location
    WA
    Posts
    23

    Default

    I've got a similar issue also. In my 97 while I was driving the vent switched to defrost only and went full cold. The heat and vent selectors just won't do anything anymore. The fan switch works fine though and all fuses are fine. I thought it was really weird that it changed the settings while in the middle of my drive. I also checked the rear air system in the sub and it is working properly.

  7. #7
    Join Date
    Jul 2012
    Location
    WA
    Posts
    23

    Default

    So I pulled out the HVAC controls in the dash and found that one of the printed wires on the ribbon cable was burnt up. I guess I found my problem.

  8. #8
    Join Date
    Oct 2010
    Location
    Scugog Island Ontario Canada
    Posts
    203

    Default

    Good find.

  9. #9
    Join Date
    Sep 2007
    Posts
    329

    Default

    I can't take any more of working in this heat without the vent working on my truck AC. The vents will move to the defrost or cab position but it takes so long I'm miserable in the summer and, obviously there will be problems when I need to defrost the windshield this winter.

    I'm going to try to take a day off and fix the vents or at least find out what may be wrong. My truck is a 1997. Hopefully, it will either be an easy fix or I can get any parts I need from Rock Auto. Where should I start? Thanks.
    1997 Silverado 1500 6.5. with 185,000 miles. New fuel injection pump at 132,000 mi. FSD Heat-Sync in bumper hole, marine fuel injectors, air induction kit all from Walt at 148,000 mi. Replaced OEM Fuel Filter Assy, wastegate solenoid valve, OPS and relay at 155,000 mi. Harmonic Balancer replaced. Red dot and White dot EGR replaced. New starter, Instant Heat glow plugs, and glow plug relay/controller at 180,000. Replaced hydroboost and master cylinder in 2016.

  10. #10
    Join Date
    Oct 2010
    Location
    Scugog Island Ontario Canada
    Posts
    203

    Default

    Look at the electric door motors.

    On my truck the wind from the blower blew the actuator lever off the door rod up above the throttle,a little silicone and some nimble fingers put it back on and problem solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •