SSDieselSupply.com
SSDPro-Exhaust.com
Results 1 to 4 of 4

Thread: Metal in filter housing

  1. #1
    Join Date
    Mar 2009
    Location
    Folsom, CA
    Posts
    207

    Default Metal in filter housing

    Would metal flakes in the stock filter housing indicate an injection pump on the way out? They seem mildly magnetic. I have a secondary spin-on filter between stock and IP so Iím not terribly worried about contamination getting back into the pump. For what itís worth I recently put a manual power switch on the lift pump. (I gave up on the stock system, ops, relay, etc.)
    Mike
    1994 K2500 Suburban 320,000 mi., F VIN, 4L80E, 3.73 w/posi., 3" turbo back, no cat, FSD Heat Sync, #9 resistor, SSD heads, SSD intake, fuel miser injectors, Bastard IP (5068), 4x4 posi (manual front axle lock), Cooling upgrade w/duel 180į t-stats and d-max fan

  2. #2
    Join Date
    Feb 2007
    Posts
    2,944

    Default

    Hi Mike, you are loosing it, the metal is coming from the tank end of the system, perhaps the lift pump. The Lift pump over ride is a good fix for the original system, both of my GMCs have direct connection to the ignition.
    Grant H.
    1995 6.5 turbo GMC K2500 extra cab 4x4 pickup, PMD under bumper, mechanical wastegate, 228,000 miles, rebuilt engine, 4.10 diff, 16 mpg
    1994 6.5 turbo GMC K2500 4x4 suburban #9 resistor, PMD in the bumper, mechanical waste gate, 226,000 miles, new engine, 0 miles. 3.73 diff, 16 mpg
    1982 4x4 shortbed 6.2 Chev 260,000 miles untouched motor 17 MPG 4.27 diff. Best thing I ever owned, since 1992.

  3. #3
    Join Date
    Mar 2009
    Location
    Folsom, CA
    Posts
    207

    Default

    Thanks, Grant. I just replaced the LP so it looks like I need to just clean out the filter housing and replace the filter. I really hate the design, the fact that all the dirty fuel spills out of the filter into the housing, that's why I got the secondary filter. What prompted all of this was a surging at idle and excessive smoke out the tailpipe. So I suspected the IP, knowing it is one of the older components on the engine. Looks like the beloved PMD was going because the surging went away when I replaced it. However I still have smoking issues. I'll drive it a bit and see if it lets up.

    Good to hear you got your Suburban up and running.
    How are things in Old Mexico?
    Mike
    1994 K2500 Suburban 320,000 mi., F VIN, 4L80E, 3.73 w/posi., 3" turbo back, no cat, FSD Heat Sync, #9 resistor, SSD heads, SSD intake, fuel miser injectors, Bastard IP (5068), 4x4 posi (manual front axle lock), Cooling upgrade w/duel 180į t-stats and d-max fan

  4. #4
    Join Date
    Feb 2007
    Posts
    2,944

    Default

    Hi Mike. Good that one of the problems is cured. I put a secondary filter on the GMC truck, because particles had got into the IP. Was the smoke black? It has been hot here, too hot to work, and my mini split AC arrived in the middle of summer, so it is only half installed. Hopefully your smoke diminishes.
    Grant H.
    1995 6.5 turbo GMC K2500 extra cab 4x4 pickup, PMD under bumper, mechanical wastegate, 228,000 miles, rebuilt engine, 4.10 diff, 16 mpg
    1994 6.5 turbo GMC K2500 4x4 suburban #9 resistor, PMD in the bumper, mechanical waste gate, 226,000 miles, new engine, 0 miles. 3.73 diff, 16 mpg
    1982 4x4 shortbed 6.2 Chev 260,000 miles untouched motor 17 MPG 4.27 diff. Best thing I ever owned, since 1992.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •