SSDieselSupply.com
SSDPro-Exhaust.com
Results 1 to 4 of 4

Thread: losing antifreeze

  1. #1
    Join Date
    Dec 2006
    Posts
    15

    Default losing antifreeze

    hi guys. just replaced pmd with fsd, new marine injecters and new glow plugs in 95 2500 6.5 turbo diesel suburban. 171000 miles .runs awesome. a year ago flushed cooling system and since have had low coolant warning sometimes and have lost about a gallon in 5000 miles. i cannot find leak hav e replaced senser in coolant tank did not have heat upon warm up until engine revved up. no hydrocarbons in fluid runs great. any ideas? no leakage from heater. had all pipes to back air conditioner replaced last summer. thanks. dr. peter

  2. #2
    Join Date
    Dec 2006
    Location
    Delaware
    Posts
    46

    Default

    Dr. Pete:

    Probably the notorious GM cracked head. Sorry for the bad news.

  3. #3
    Join Date
    Dec 2006
    Location
    Chilliwack BC Canada
    Posts
    676

    Default

    Check the water resevor for oil film and check for bubbles when its running. If there is a head crack or gasket problem you will usulally see bubbles in the coolant ...Garth

  4. #4
    Join Date
    Dec 2006
    Location
    South Louisiana
    Posts
    45

    Default

    Dr. Peter
    2 years ago I had the same issue. Didnt pay much mind to it. When the head gasket blew and the engine was locked up (water on top the cylinders), I took my heads off and low and behold, those two heads had so many cracks it looked like a road map. Once i replaced the heads with new gaskets, the coolant dissappearing act ended.

    Sorry for the bad news,
    Floyd

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •