SixFiveTurboDiesel.comSixFiveTurboDiesel.com
SSDieselSupply.com - SSDiesel Supply
SSDPro-Exhaust.com, an SSDiesel Supply Company

Go Back   SixFiveTurboDiesel.com > Main Category > Main Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 02-24-2008, 04:41 PM
don bad don bad is offline
Member
 
Join Date: Dec 2007
Posts: 39
Default Transmission wont shift, tach stuck on zero, speedometer stuck on 45mph

Hi everyone,


My vehicle feels like it wont come out of second gear. Also it feels like it starts in second gear. The tach is on 0 and the speedometer is stuck on 45.

Also, I am not getting fuel to the filter, atleast enough to keep it running at wot.

Thanks for any help.

Don
Reply With Quote
  #2  
Old 02-24-2008, 08:42 PM
grancito's Avatar
grancito grancito is offline
Senior Member
 
Join Date: Feb 2007
Location: Baja California Sur Mexico
Posts: 2,673
Send a message via MSN to grancito Send a message via Skype™ to grancito
Default

Bad ignition switch/fire wall ground?
__________________
Grant H.
1994 6.5 turbo GMC K2500 HD suburban "F" VIN FSD heat sync #9 resistor, PMD in the bumper, no cat, mechanical waste gate, 220,000 miles, 4L80E Positrac 3.73 diff, 17 mpg highway.
1982 4x4 shortbed 6.2 Chev 260,000 miles untouched motor 17 MPG 4.27 diff. Best thing I ever owned, 21 years.
Reply With Quote
  #3  
Old 02-24-2008, 08:49 PM
don bad don bad is offline
Member
 
Join Date: Dec 2007
Posts: 39
Default Hi

I just replaced the ignition switch. What firewall ground should I check?

Thanks,

Don
Reply With Quote
  #4  
Old 02-24-2008, 09:15 PM
grancito's Avatar
grancito grancito is offline
Senior Member
 
Join Date: Feb 2007
Location: Baja California Sur Mexico
Posts: 2,673
Send a message via MSN to grancito Send a message via Skype™ to grancito
Default

Look along the wall above/behind the engine for grounded wires, they change positions depending on year. Also could be the ignition switch harness, if it was only a gage problem then pulling the instrument panel and cleaning the contacts can cure that.
__________________
Grant H.
1994 6.5 turbo GMC K2500 HD suburban "F" VIN FSD heat sync #9 resistor, PMD in the bumper, no cat, mechanical waste gate, 220,000 miles, 4L80E Positrac 3.73 diff, 17 mpg highway.
1982 4x4 shortbed 6.2 Chev 260,000 miles untouched motor 17 MPG 4.27 diff. Best thing I ever owned, 21 years.
Reply With Quote
  #5  
Old 02-24-2008, 10:25 PM
mamzerook's Avatar
mamzerook mamzerook is offline
Junior Member
 
Join Date: Sep 2007
Posts: 10
Default

Quote:
Originally Posted by don bad View Post
Hi everyone,


My vehicle feels like it wont come out of second gear. Also it feels like it starts in second gear. The tach is on 0 and the speedometer is stuck on 45.

Also, I am not getting fuel to the filter, atleast enough to keep it running at wot.

Thanks for any help.

Don
stuck in second is indicative of limp mode. ses lite on? check for codes, there should be at least one
__________________
1995 K3500 DRW 6.5TD F 4L80E high idle switch, manual TCC lock-up, air box mods, snorkelectomy, K&N filter, 4" with flowmaster and 5" tip, autometer boost pyro and tranny gauges, Max-E-Tork v2.0
Reply With Quote
  #6  
Old 02-24-2008, 10:35 PM
grancito's Avatar
grancito grancito is offline
Senior Member
 
Join Date: Feb 2007
Location: Baja California Sur Mexico
Posts: 2,673
Send a message via MSN to grancito Send a message via Skype™ to grancito
Default

He's got 15 48 84 99, too many at one time, indicates an obscure problem, that's why I say ground, or connections. He has just replace the IP so may have disturbed a connector.
__________________
Grant H.
1994 6.5 turbo GMC K2500 HD suburban "F" VIN FSD heat sync #9 resistor, PMD in the bumper, no cat, mechanical waste gate, 220,000 miles, 4L80E Positrac 3.73 diff, 17 mpg highway.
1982 4x4 shortbed 6.2 Chev 260,000 miles untouched motor 17 MPG 4.27 diff. Best thing I ever owned, 21 years.
Reply With Quote
  #7  
Old 02-24-2008, 10:49 PM
don bad don bad is offline
Member
 
Join Date: Dec 2007
Posts: 39
Default Hi

I have 3 codes 81,82,83. I am starting to think Ground, possibly the one on the block. Should I run another ground somewhere. I still don't get the tach on 0 and speedo on 70 now. And the shift indicator isn't on.

Don
Reply With Quote
  #8  
Old 02-25-2008, 10:32 AM
don bad don bad is offline
Member
 
Join Date: Dec 2007
Posts: 39
Default Now I am getting a code 29 also

I checked grounds the one on the front passenger side of the block and the one at the back of the block same side. Also, drivers side. Does anyone know any others? I will check connections now, and hopefully we can find a problem. The codes are all transmission ones, and the other thing is that there is no tach and mph is stuck at 70. Also, no shift indicator light.. I just noticed that my headlights wont come on either.

Thanks,

Don
Reply With Quote
  #9  
Old 02-27-2008, 10:14 PM
grancito's Avatar
grancito grancito is offline
Senior Member
 
Join Date: Feb 2007
Location: Baja California Sur Mexico
Posts: 2,673
Send a message via MSN to grancito Send a message via Skype™ to grancito
Default

Forget the engine grounds, that causes the starter not to work, look for body grounds, come off the batteries to the inner guard.
__________________
Grant H.
1994 6.5 turbo GMC K2500 HD suburban "F" VIN FSD heat sync #9 resistor, PMD in the bumper, no cat, mechanical waste gate, 220,000 miles, 4L80E Positrac 3.73 diff, 17 mpg highway.
1982 4x4 shortbed 6.2 Chev 260,000 miles untouched motor 17 MPG 4.27 diff. Best thing I ever owned, 21 years.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.